Info Bang Maman
Thursday, 08 Dec 2022
  • BELAJAR BELAJAR DAN BELAJAR SUATU SAAT APA YANG KITA PELAJARI AKAN BERMANFA'AT BUAT DIRI KITA KELUARGA KITA DAN ORANG-ORANG YANG ADA DI SEKITAR KITA

Automatisasi blokir ip address berdasarkan hostname

Diterbitkan : - Kategori : MIKROTIK

Drop (blokir) ip address dari dhcp lease yang tidak diinginkan berdasarkan hostname, disini saya berikan contoh semua yg memakai hp android:

script 1 : melakukan pencarian di filter, jika ip yg dimaksud ada maka akan di hapus terlebih dahulu agar tidak terjadi dupilkasi

:local ipfilter value=[/ip firewall filter find]; :foreach looping in=$ipfilter do={:local komen value=[/ip firewall filter get $looping value-name=comment]; :if ($komen=”android”) do={/ip firewall filter remove $looping}};

script akan saya namakan : hapus-filter-android

Script 2 : menambahkan ip address pada firewall filter lalu di lakukan drop (blokir) agar android tidak dapat mengakses internet.

:local bnyklease value=[/ip dhcp-server lease find]; :foreach looping in=$bnyklease do={:local namahost value=[:pick [/ip dhcp-server lease get $looping value-name=host-name] 0 7]; :local ipadd1 value=[/ip dhcp-server lease get $looping value-name=active-address]; :if ($namahost=”android”) do={/ip firewall filter add chain=forward action=drop dst-address=$ipadd1 disabled=no comment=$namahost}};

script akan saya namakan : drop-android

jika script diatas sudah dibuat maka kita tinggal membuat schedule atau jadwal untuk mengeksekusi script.

untuk menambahkan 2 script diatas di 1 scheduler maka scriptnya seperti berikut :

/system script run hapus-filter-android

/system script run drop-android

sumber : https://www.facebook.com/notes/wong-lawas/automatisasi-blokir-ip-address-berdasarkan-hostname-dengan-script-scheduler-di-m/684255344977928

Post Terkait

PPPoE server Dan PPPoE Client

Tuesday, 1 Nov 2016

Job Sheet 3 Mikrotik

Thursday, 20 Aug 2015

Job Sheet 2 Mikrotik

Thursday, 20 Aug 2015

Blok Youtube pada Mikrotik

Wednesday, 1 Oct 2014

QoS dengan PCQ dan Queue Tree

Tuesday, 23 Sep 2014